Adium

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#10074 closed defect (fixed)

Contact list toolbar overlaps a few pixels of the contact list content

Reported by: sengelking Owned by: zacw
Milestone: Adium 1.3.2 Component: Adium Core
Version: Severity: regression
Keywords: Cc:
Patch Status:

Description

Nit-picky issue, but after installing the latest version of Adium 1.3b2 today, the top field in the buddy list is incorrectly spaced too high.

Love the program!

Sean

Attachments (2)

Picture 1.png (55.1 KB) - added by sengelking 11 years ago.
See spacing for AL272727
white stripe over groups.png (62.8 KB) - added by Melebius 11 years ago.

Download all attachments as: .zip

Change History (18)

Changed 11 years ago by sengelking

Attachment: Picture 1.png added

See spacing for AL272727

comment:1 Changed 11 years ago by Robert

Milestone: Adium X 1.3
Owner: changed from nobody to Zachary West
priority: normallow
Severity: normalregression
Version: 1.2.51.3b2

comment:2 Changed 11 years ago by Jordan

Version: 1.3b21.3b3

I can reproduce this with 1.3b3 @ OS X 10.5.3 - steps to reproduce are as simple as View > Hide Groups

comment:3 Changed 11 years ago by Robert

Actually, this also affects groups. One or two pixels are just cut off the top.

comment:4 Changed 11 years ago by Jordan

Summary: Buddy list spacing issue with Adium 1.3b2Contact list toolbar overlaps a few pixels of the contact list content

comment:5 Changed 11 years ago by Zachary West

There's a lot of areas of code where there's off-by-one-pixel problems in the contact list. I'm going to go through and try and set it all correctly.

comment:6 Changed 11 years ago by Evan Schoenberg

Any luck, Zac?

comment:7 Changed 11 years ago by Zachary West

I think we're setting the location too high, and were compensating that by calculating the height correctly, but continuing to position wrong. That's why an extra pixel of space pops up when contacts sign on/off, etc. I haven't had a chance to go through and fix it. I think my fix to correct the pixel of blank space at the bottom of the contact list was wrong: the solution was probably to shift the contact list back into the right position.

comment:8 Changed 11 years ago by Jordan

Milestone: Adium X 1.3Adium X 1.3.1

Due to the non-urgency of this, it may as well wait for 1.3.1...

comment:9 Changed 11 years ago by Jordan

Milestone: Adium 1.3.1Adium 1.3.3

comment:10 Changed 11 years ago by Colin Barrett

Milestone: Adium 1.3.3Adium 1.4

comment:11 Changed 11 years ago by Evan Schoenberg

Milestone: Adium 1.4Adium 1.3.3

This is a 1.3 regression, probably from the contact list search bar. I'd prefer to continue to target 1.3.x, and I think regressions shouldn't be tolerated.

comment:12 Changed 11 years ago by Zachary West

Resolution: fixed
Status: newclosed

(In [25143]) Move the origin of the contact list view up by 1, and increase its vertical padding by 1. This, somehow, fixes #10074. I'm at a loss for words how it does it, or what code was assuming it worked this way, but my brain hurts too much to try and figure out any more. There's still an off-by-1 error in height when animations are taking place; I'm not able to track that down either.

comment:13 Changed 11 years ago by Zachary West

(In [25144]) Merged [25143]: Move the origin of the contact list view up by 1, and increase its vertical padding by 1. This, somehow, fixes #10074. svn is also pushing a lot of property changes so I say, what the hey, why not; it's your party, you can cry if you want to, svn.

comment:14 Changed 11 years ago by Zachary West

Milestone: Adium 1.3.3Adium 1.3.2

Changed 11 years ago by Melebius

comment:15 Changed 11 years ago by Melebius

After installing 1.3.2, a white stripe started to appear over the first group in my buddy list (picture “white stripe over groups.png”) and I think it has something to do with changes described above.

comment:16 Changed 11 years ago by Robert

That's #11119.

Note: See TracTickets for help on using tickets.